My Lawnmower Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello I'm trying to find out more about the 1991 Toro wheelhorse 520-H I have one that's been sitting for a year or two, and doesn't want to start. I got power to the starter but the solenoid won't engage, or do any thing. I'm not sure if I should take the starter off or keep testing? I don't think any thing is locked up (I can move the flywheel with a screwdriver) Any suggestions would be appreciated.
 

·
Premium Member
Joined
·
7,358 Posts
:welcome: to MLF!

It could be a problem with the solenoid itself or that it's simply not getting enough power to crank it over.

For starters, have you tried tapping it with a mallet? Sometimes this will help break them free if they're stuck.

If this doesn't do the trick, I would check to see what the voltage reading that you're getting to the starter is. It may be that there are some corroded connections where it's loosing amps before it reaches the starter and is not enough to engage it.

After doing all this and it still doesn't work, then I'd pull the unit apart and see if I could fix or replace it.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top