My Lawnmower Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi everyone,

I have recently aquired a ransomes T51D batwing gang mower that requires some maintenance work. The mower was manufactured in 1995 and runs and cuts well, all hydraulics work smoothly and overall is in good condition.

The mower looked like it hadnt been serviced in a long time - I will change all fluids and filters - the one concern I have is when all decks are down and cutting it is very slow getting up hills (it has a hydrostatic transmission) I suspect changing the main hydraulic pump (expensive) is the only solution. Does anyone have any ideas to try before doing this?

Any suggestions would be greatly appreciated
 

·
Premium Member
Joined
·
6,106 Posts
Hello Mau Mau. I'd see how it operates after the fluid an filter changes before digging into replacing the pump.
 

·
Administrator
Joined
·
6,224 Posts
Welcome to the forum mau mau! :)

I vote with BW, go with the oils and filters first and see what happens. Looks like by pictures I found the decks are also hydro motor driven so if it works OK until all the hydro motors are running I would agree it does sound like lack of flow or running a little low on pressure. A dirty filter could sure aggravate a problem like that. Also might want to take a close look at the hydro lines for deterioration. Make sure they are not sending bits and pieces of themselves throughout the system. ;)
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Thanks for the replies guys - think we may have found the problem

Noticed when using mower today there is a lot of travel in the pedal before any drive is engaged - looked at linkage underneath mower and found lots of wear in the pins and rods - tightened this all up and now much more power getting to wheels.

Will give everything a good service now and no doubt will be back to pick your brains when I hit the next problem

Thanks again.
 
1 - 5 of 5 Posts
Top