My Lawnmower Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a Toro 529H-has been a great little mower..until this year. Just got it back from having serviced-by local friend of the family - he refurbs, sells and services mowers (older gentleman). When it came back, I noticed the deck will not raise - he kinda hinted that there was no way to raise/lower the deck-I knew better but was losing the argument. When I check the fluid - it was totally empty so I don't know if he forgot to fill it or what-no indication of leaks, so I filled thinking I had it fixed - didn't work, but fluid staying in. Found some fuses..none blown - removed each fuse, cleaned connectors - used compressed air and cleaned spots to put them back - nothing! I'm at my wits end! Also..now it runs for a while and then acts like running out of gas - check fuel - then noticed that the fuel filter bowl was not full - - let it set for a while, went back, it started - used it for a while - then again....acted like running out of gas and stopped - - let set for a few hours..started but didn't run to its capacity - Checked wires from the switch to the harnass - saw no cuts/disconnects, etc.
Any suggestions on what else I can try? Money is tight and I just put $130 in it-would like to be able to do on my own - - if possible (and sensible!lol)

Thanks - all help appreciated.....my grass....is growing as we speak!! lol:dunno:
 

·
Premium Member
Joined
·
9,015 Posts
Well first off welcome. You sound like you have multiple issues. The carb float is not letting fuel in or pump issue by sound of it. I would have this fellow fix your machine right if you paid for the service. Sounds like alot of corners cut.
 
  • Like
Reactions: BCreager

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
May have to - just didn't want to wait for him to come pick it up for me - there aren't many around that will do that - and although I have a truck, it's hard to get it on there - bring it back home and unload - plus, he wasn't convinced I knew what I was talking about when I showed him the hydraulic button for the deck - (forgot to mention...my name is Barb...was raised as a son - explains some knowledge and eagerness to try! lol ) - But, it is there, it did work..and now it doesn't.

May give him a call and try again - just want to save some if I could - SS doesn't go very far these days!!

Thanks.
 
1 - 3 of 3 Posts
Top