My Lawnmower Forum banner
1 - 12 of 12 Posts

· Premium Member
Joined
·
9,020 Posts
Discussion Starter · #1 ·
Well the Fusion had this issue of going into limp home mode from beginning. Very rare, only happened 5-7 times in the years of owning it. Brought it into dealer at least 4-5 times and they ignored it twice, told dad another time with my K&N and BOV they won't touch it. Last time I removed all the stuff to detriment of my lower back. They could not find a issue of course, I had code P061B on my scan tool. Well it did it again with my stuff not being on for a month or so. Told Advisor of that and then it is your factory stuff causing problem. We drop it off Tuesday morning and I called Weds night. They say still working on it. I had therapy Thurs so drop by dealer, car is in SAME SPOT I parked it in and rotors are very rusty from sitting after raining!! Now I am not very happy! ( I left my dash cam on and car will time out after 30 minutes so have proof ) Go in and ask if it is done while I am in town. The advisor states the service manager needs to look at it? Go home angry and get a call at 2 that day. Advisor says he is "pushing through" a throttle body replacement as no problem can be found. Today I have eye DR appointment so bother dad AGAIN and stupid office lets me sit 2 HOURS before DR sees me, what a waste of a day! After dilating my eyes feel driving at dusk not a great idea and scrap going for car, meanwhile never receive a call its done? On way home get a call at 5:05 PM saying they just got it done and can pick it up tomorrow!?! I worked in dealer, I know they blew the car off for waits and such until last second! I been without a car and been asking my daddy for rides all week!? ARGH!! Not fun! I feel I owe him gas money and time allowance I don't really have excess cash to spend. Feel the way dealers treat customers have really fallen compared to my day!
RANT OVER! ;)
God willing it works like it should tomorrow when /if I get it! Also hope it has no lot damage from being in there for almost a week!
 

· Premium Member
Joined
·
7,335 Posts
That's gotta be miserable! Hopefully they replaced some parts and have it squared away.

Doesn't your dad have a second vehicle you can drive?
 

· Premium Member
Joined
·
9,020 Posts
Discussion Starter · #3 ·
The dealer doesn't need to know that! Lol My back does not do well with dads stuff!


Sent from my iPhone using Tapatalk
 

· Registered
Joined
·
651 Posts
had something similar happen with a 92 ford tempo...well not exactly the same but with brakes...bought the car new in 92 and from day one the brakes would squeal almost every time you'd use them...dealer never did fix the problem just said it was the type of brake material...long story short, we still have the car , I use it for a work car now and after almost 25 years I finally got the brakes to stop squealing. I bought the cheapest brake pads I could find online when I opened the box and looked at them I though , man I could find something better in the junkyard , but they do work and are quiet....so it only took me 25 years to fix the problem ...lol... but I do know what you mean being frustrated with dealers or garages in general
 

· Premium Member
Joined
·
9,020 Posts
Discussion Starter · #5 ·
Finally got it back this morning. Covered in bird crap and dirt! :( I drove it around town and seemed ok. Got it home and washed it as I hate car washes. Looked and can only see throttle body a little but is new. Checked my dash cam and see they did NOT know it was on!! :) It sat until Thursday afternoon, kid drove it erratically and went to a store, must have forgotten his wallet or something as he got right back in. Drove it to garage and parked it. Sat until yesterday at 4:10PM!! The guy did throttle body and guess he needed to move the car to get it on lift and started it, it sounded like it raced to almost red line!! Another tech is heard saying WTH? Guy stated it sucking air. He gets it done and drove it around. I was called by Advisor last night and told to get car today, when he called the tech wasn't done yet!? He parked it at 5:40PM after they had car since Tuesday morning! Love the auto industry, customer service is job one! :(
Here she is safe in driveway at least!
 
  • Like
Reactions: Florin and wh55

· Premium Member
Joined
·
9,020 Posts
Discussion Starter · #7 ·
Decided to change oil today to check on any not well done work as he went underneath according to camera. Also time for snow tires, left them off so Ford could not say that was cause of light! We are going to put it on lift and raise it just high enough to get tires on/odd. Then raise it high enough to lay under or whatever is comfortable for me to get to work. Will most likely pay for it tonight!
 

· Premium Member
Joined
·
9,020 Posts
Discussion Starter · #8 · (Edited)
Well got the oil and filter thank God I got a filter. I inadvertly used the oil filter on Husqvarna Kohler oil change!! It fit good too! Will much help from dad as actually getting undercar and removing the cover and changing oil would have hurt ( He did it! ) We also together got the wheels off with lift just high enough to clear them from floor. I then painted the calipers, they finally look crappy. I liked the silver look of factory until of late. Could not find yellow as red on red car seemed overdoing but had to settle. Black would look factory to me!? Think it came out good. Just painting those hurt as I had to bend over for a bit. Thankful to have all maintenance done for now!














 

· Registered
Joined
·
191 Posts
Sorry to hear about the woes of dealing with idiots. It's a shame that SOME dealers will give the customer the run around. I own 2 LS430's and have the Lexus Service Facility do all the maintenance on the cars. They treat me well every time I go in there. The oil change with Synthetic oil costs me 58 dollars, and they clean and detail the car, give me a loaner if i need it, have the best waiting lounge of any dealer in the country and they do it all with complete professionalism.

Perhaps there's another facility you can take the car to?? No need in giving them any more money...

On a side note, I too installed my winter tires today. I'm all ready for snow.... If it ever shows up...
 

Attachments

· Premium Member
Joined
·
9,020 Posts
Discussion Starter · #10 ·
Hi only reason I go to this dealer is warranty service. No other dealers close by. Nice Lexus!! I always liked those cars! You got the V8 right?


Sent from my iPhone using Tapatalk
 

· Registered
Joined
·
191 Posts
Nice Lexus!! I always liked those cars! You got the V8 right?

Sent from my iPhone using Tapatalk
Yes, it's the 4.3 liter 300hp V8. It actually does very well on fuel economy too. I commute between Milwaukee and O'Hare airport in Chicago (74 miles) and I'm averaging 27-28 mpg on the freeway. I love driving this thing. I just don't get fatigued driving it.

Also attached a photo of my other LS. That was taken when we bought it back in April 2016.
 

Attachments

· Premium Member
Joined
·
9,020 Posts
Discussion Starter · #12 ·
Those cars sure are nice! Glad it is great fit in your commute! My car been treating me well now!


Sent from my iPhone using Tapatalk
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top