My Lawnmower Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
I was mowing just fine.My mower decides to stop mowing.
There is no fire on sparkplug. So I am thinking kill switch has gone bad some where only I can't find them. I did the extra starter breaker instalation.

Mower specs. are

John Deere STX 38 Tractor
yellow deck
Product # MOOSTXBO34381

Engine
Kohler Command 13
Family SKH398U1G2RB
CV-13s
spec. 21509
Displace CC 389
Ser.# 2613607342

Oil filter # AM125424

Thanks a bunch for Your help!
 

·
Founding Administrator
Joined
·
1,256 Posts
Well, it could be one of the safeties, seat, brake, blades. You could possibly have a short in the kill wire, key switch, or a bad coil. Sounds like a lot could be wrong, but just start by process of elimination. Go to the Kohler website and download the .pdf version of the service manual for this engine. You will not regret having this available as you go about your troubleshooting.

Does the engine turn over when you put the switch to the "Start" position?
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #3 ·
Doorkeeper

Well, it could be one of the safeties, seat, brake, blades. You could possibly have a short in the kill wire, key switch, or a bad coil. Sounds like a lot could be wrong, but just start by process of elimination. Go to the Kohler website and download the .pdf version of the service manual for this engine. You will not regret having this available as you go about your troubleshooting.

Does the engine turn over when you put the switch to the "Start" position?
Yes the engine turns from ignition key.No fire on sparkplug.
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #6 ·
Doorkeeper

I think that it has to be either a short in the kill wire, ignition switch, or a faulty coil. Start with the kill wire, I would suggest, and go from there.
I am to old to let this excite Me. I'll keep You'll informed as I make progress on this one.
Thanks You are a GREAT group'
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #7 ·
Well I got the stx 38 running. I tested the coil for circuit,it tested okay,leg mouts and all were covered in rust magnets on flywheel too.
I ran it for about 20 minutes and it killed the battery. Now I am going to check the wiring and power on stator regulator. As soon as I learn how.
This mower was jjj when I got it. For a spare & I got two at the time.
 
1 - 7 of 7 Posts
Top