My Lawnmower Forum banner
1 - 20 of 27 Posts

·
Premium Member
Joined
·
9,015 Posts
Discussion Starter · #1 ·
Hi guys, figured the weather is making it the right time to repair or troubleshoot the SS10. I went to fire it up before we hit gym and she fired easily! It was 35%F I think, started on 1/2 choke, so this is my one issue on firing it on cold starts, too much choke!
I caught the side of road and concrete and belt the locator channel on plow in frame. It was also like this when we bought it, so further damage. I took advantage of break in rain to Seafoam engine ,couldn't hurt.
We removed the plow and found a lot of bent metal!
Dad came up with a great idea to weld shoulder bolts cut to locator pins to lengthen then to get them in channel better. We straightened the metal as well as could be done with room we had. It is much better. I removed the side panel and replaced the factory ground and checked the positive cable, which looked fine. I lubricated everything I could reach and reinstalled panel. We ran out of time to repair leaking carb bowl. Dad had installed a sheetmetal side wing to see if it was a good idea! I LOVED IT! I had just gotten some scrap SS from my job and they will work GREAT for wings!! We got one installed for now, will finish tomorrow!!
The Generator is working well in warm weather and seemed SUPER not easy to remove. I will not mess with it unless I have too!
Any thoughts of what I should look at this point!??
















 

·
Administrator
Joined
·
7,359 Posts
Nice work! :cool

Always a good feeling to get stuff done like that.
 

·
Premium Member
Joined
·
9,015 Posts
Discussion Starter · #4 ·
Thanks Austen! God willing it works as it should in cold weather now?!
tiretrx, thank you! Can you believe a guy TRADED it to me with a Snapper RER for a John Deere 111 we restored???
I got the BETTER deal! This old girl is like new! I don't think it was restored, just preserved!
 

·
Premium Member
Joined
·
9,015 Posts
Discussion Starter · #6 ·
Thanks motor! The carb was clean and dad resealed the drain bolt. Turned out the main needle also leaked, did not notice until AFTER all together! Dad had to leave early today, so it is better than before. Will work on it when able. We use shut off anyway! Dad thinks the wing on both sides would make it too big, so will leave it on one side for trial basis!
 

·
Premium Member
Joined
·
9,015 Posts
Discussion Starter · #7 ·
The choke cable came in that I broke last week. It is too long, so made it work by routing it long way! The carb bowl was leaking again, ordered a new one, no show yet. Dad resealed it with another material, seems good at moment!
She plowed great today ,we got 3-4" of snow today!
Dad also found a cheap way to support the stack, use the belt guide from other attachments!! Seems to work great!!! ;) Love his ingenuity!!




 

·
Premium Member
Joined
·
9,015 Posts
Discussion Starter · #9 ·
Bruce, when dad mentioned it, I was skeptical! When I seen how tight it fit to pipe and then the clamp idea!! I was impressed!! :) Easiest fix in a long time!!
 

·
Premium Member
Joined
·
9,015 Posts
Discussion Starter · #11 ·
Sure did motor! I plowed with it today, started after lengthy cranking. The generator seems to need to warm up on these super cold days too! She worked great when fired up! Plowed a lot with it and no gas leak!! YEA!! Happy! Even broke out the ST-12 and blew some!
 

·
Premium Member
Joined
·
1,228 Posts
Glad you got some good seat time, Eric. Like the exhaust fix too, pretty smarty :idea:
 

·
Premium Member
Joined
·
9,015 Posts
Discussion Starter · #14 ·
Thanks Ellis! Dad had a great idea! Worked like a charm!
 

·
Premium Member
Joined
·
9,015 Posts
Discussion Starter · #16 ·
Thanks Mike!! One of my favorite tractors!
 

·
Premium Member
Joined
·
9,015 Posts
Discussion Starter · #17 ·
Well praise God it looks like my issues are repaired!! Went out to use the plow in the nor'easter today. Its 15% when I tried to fire it up. Don't engage choke until it is spinning some, then pull all the way. She fired easily!! Let it warm up and it plows very nice and clean!! I am happy ! No fuel leaks I saw either! We changed the oil before and it helped some too!! ;)
 

·
Premium Member
Joined
·
9,015 Posts
Discussion Starter · #19 ·
Thank God motor! Needed it today! It pushes a lot before it come to a spinning stop! Just too much weight to push I guess!
 
1 - 20 of 27 Posts
Top