My Lawnmower Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter · #1 ·
Hi guys, I recently bought a husqvarna rider with 18.5 Briggs ELS series single cyl. The problem with it was the cam lobe wore off. I had Briggs 13.5 ohv parts engine that I took the donor cam from and installed in the 18.5... It's together and seems fine.
However... The donor engine did not have an oil filter and oil pump on the sump therefore the cam did not have a slot in the end to drive the pump. In order for it to be installed I had to use the donor sump as well.
Do you all think it will hold up with just the oil sliger doing the work as many engines don't have external filters? Also is the pump there mainly to provide circulation to the filter?
Thanks for reading!
 

·
Registered
Joined
·
50 Posts
Does the rod have the dipper on it to sling the oil, if so I think you will be ok, you could have put a new cam and valve tappet ends and use old case.
 

·
Administrator
Joined
·
7,693 Posts
I believe that the engine you are replacing has pressure lube to the top main bearing. If that's true, I'm not sure that a slinger would work. Besides, the oil slinger in a vertical engine is not on the rod; it's a separate, gear-driven part that rides on its own shaft usually.
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #4 ·
It's held together for a couple weeks now. Maybe 50 starts, multiple runs to the mailbox (100 yds.) Mowed for 30min with it since. I start and run my few mowers several times a day , a few days a week. Still wonder if the oil pump is of concern?
 
1 - 5 of 5 Posts
Top