My Lawnmower Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi All. I just bought a used Z222 Toro Z-Master mower with 560 hours. This model was only made in 1997, don't know why. Perfect shape for the age, clean and dry hydraulics, 2 pumps and 2 drive motors. The bad news is the C22S 22Hp Kohler engine was backfiring and would only run on full choke. Also the PTO oil seal is pouring out oil. Seems to be worth the $520 I paid for it?
Anyway I pulled off the valve covers and found one rocker arm bolt had pulled out and stripped the threads in the engine. I installed a heli-coil and used severe red loctite on it. It is holding 15 ft lbs of torque per spec so I'm letting it cure today before trying to start the engine. Fingers crossed!
I'll attack the oil seal next after I see if the rocker arm bolt fix worked.
Seems to be a very solid machine and the 52" deck is in new condition, needs a little paint. The height adjustment is kind of unusual with the foot operated pedal, but it works fine. Thinking about adding lights in the future.
Thanks for the forum membership, I hope to learn more about Zero Turn mowers from all the experts here! As well as how to maintain my machine with as much DIY as I can. I named her "Neuman". Long story.
Dave from IL
 

·
Premium Member
Joined
·
1,547 Posts
Hello Dave & welcome to The Site!! :howdy:
 

·
Premium Member
Joined
·
1,596 Posts
Howdy and :mlf: Glad you decided to join us! We'll offer what advice we can for your ZT.
 

·
Premium Member
Joined
·
9,015 Posts
Welcome!
 

·
Premium Member
Joined
·
1,444 Posts
Welcome
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #8 ·
Z222 Progress

Well I got the heli-coil installed, applied the red loctite then instlled the rocker arm bolt in the head and let it cure overnight. I tried it but it didn't start! I tinkered with the carb controls and found the throttle rod was messed up. After all that she started with a cloud of smoke after running on 1 cylinder for so long. She smoothed out after adjusting the slow speed mixture screw. Nice low rumble. Looks like the heli-coil fix is going to hold.
Next I'm tackling the PTO shaft oil seal. Everything slid right off after being soaked with oil from the leak. I have the new seal and watched Taryl on YouTube on how to install it. His trick using a sheet metal screw and a improvised slide hammer worked like a charm getting the seal out.

Question for the group... do I apply loctite to the seal OD?

Messy job but I hope it will be completed soon. I'm enjoying reading the forum, not much discussion found on Toro ZTurns. My left gas tank is not feeding to the right one though. I need to fix tha too. Always something.
Dave
 
1 - 8 of 8 Posts
Top