My Lawnmower Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Joined the forum to see if anyone has a solution to a Toro SR4 problem. It's ten years old, and while mowing the lawn this morning the Personal Pace drive crapped out. Actually, don't think anything is wrong with the drive, the handle to activate it froze up solid, won't move at all. Took that section of the handle off to get a better look, but couldn't see anything that was jamming it. The cable is free, but the handle is locked up solid!!! I had to finish mowing, and that mower is a beast to push when the self-propelled system craps out!
 

·
Banned
Joined
·
343 Posts
Joined the forum to see if anyone has a solution to a Toro SR4 problem. It's ten years old, and while mowing the lawn this morning the Personal Pace drive crapped out. Actually, don't think anything is wrong with the drive, the handle to activate it froze up solid, won't move at all. Took that section of the handle off to get a better look, but couldn't see anything that was jamming it. The cable is free, but the handle is locked up solid!!! I had to finish mowing, and that mower is a beast to push when the self-propelled system craps out!
if every thing else works. then you will have to get a handle assembly. it would also help if you could post a vid of this problem that is presenting itself to us.
 

·
Premium Member
Joined
·
9,015 Posts
Welcome!
 

·
Administrator
Joined
·
7,359 Posts
:mlf:
 

·
Premium Member
Joined
·
1,444 Posts
Welcome
 
1 - 8 of 8 Posts
Top