My Lawnmower Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I recently purchased a set of Gator blades and a mulch plug for my 22v42. Got the blades installed and put the plug on but when I fired it up and took it for a test ride, I was showered with clippings which were ejected from a hole in the top of the plug. Contacted the seller and all he could offer was a half refund for the plug. So, the reason for this post is based on the picture, do I have the right plug and if not, is there a better one available? Any info would be appreciated.

 

·
Ret. Moderator
Joined
·
498 Posts
I don't know a reason for it , but do you think it is missing a rubber grommet that goes in there ?
 

·
Ret. Moderator
Joined
·
498 Posts
Ok I have an answer sort of . Looking up this part it is multi fit . It fits Husqvarna , Craftsman , and Poulan Pro . On the Poulan Pro there is a tab that the hole fits over . I will not give my opinion on a fix due to liability and safety issues . But safely , you may be able to plastic weld a piece in place or fill the hole with JB WELD being sure to overlap to hold it in place. Here is a picture of the deck the hole was made for .

 

·
Ret. Moderator
Joined
·
498 Posts
I was going into convulsions not to say that , but being a ROOKIEMOD I figured I needed to be more responsible :(
 

·
Premium Member
Joined
·
6,110 Posts
It had occurred to me the first time I saw the picture, but I didn't want to say it either.

But, I'm with you in thinking that there might be some kind of plug that is intended to go in there. It's available across different brands, but from what you said, only one of them require that hole, so maybe they have some thing for the other brands to plug it? Worth looking into and asking.
 
1 - 9 of 9 Posts
Top