My Lawnmower Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey all, first post after finding this forum while trying to solve an issue. The drive belt on my JE75 keeps slipping off. Furthermore, after the last time I replaced the belt on the pulley, the self propulsion engages, but the mower will not move. After a few moments, the belt will just slip back off again.
I noticed the belt guides are worn, so perhaps they’re giving the belt enough room to slip off, but that doesn’t explain why the mower won’t move before the belt comes off. The pulley engages & spins with the belt, the mower just won’t move. Then the belt soon just slips off the pulley altogether.
Would this be a transmission issue? The plastic cover for the speed control wire is loose in the plastic lever housing but the wire itself appears ok and is attached to the lever. Wasn’t sure if that would indicate anything important.
Anyone who can help out this novice would be greatly appreciated! Thank you!
 

·
Registered
Joined
·
27 Posts
Hey all, first post after finding this forum while trying to solve an issue. The drive belt on my JE75 keeps slipping off. Furthermore, after the last time I replaced the belt on the pulley, the self propulsion engages, but the mower will not move. After a few moments, the belt will just slip back off again.
I noticed the belt guides are worn, so perhaps they’re giving the belt enough room to slip off, but that doesn’t explain why the mower won’t move before the belt comes off. The pulley engages & spins with the belt, the mower just won’t move. Then the belt soon just slips off the pulley altogether.
Would this be a transmission issue? The plastic cover for the speed control wire is loose in the plastic lever housing but the wire itself appears ok and is attached to the lever. Wasn’t sure if that would indicate anything important.
Anyone who can help out this novice would be greatly appreciated! Thank you!
Does your wheels spin freely when you turn them by hand?? If not seems like they are locked not letting the trans to spin like it should??
 
1 - 3 of 3 Posts
Top