My Lawnmower Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I am looking for some assistance as to what my problem might be with my lawnmower. It was working fine about a month ago but when I went to cut the grass yesterday it wouldn't start. When I turn the ignition it just gives me a continuous beeping sound and the orange light comes on. The engine doesn't turn over at all and I have checked all of the following:

that the blade is not engaged, the shift lever is in neutral, the choke is in the correct position, oil level is ok, petrol level is ok, the grass compartment is empty and in place correctly, the battery is ok and the fuses are both ok.

I am out of ideas as to what else the issue might be as, like I say, it was working perfectly only a few weeks ago but has suddenly developed this starting issue.

Any assistance would be greatly appreciated,

thanks,

George
 

·
Premium Member
Joined
·
5,898 Posts
A battery can show 12 volts all day long but under a load it can go down hill real fast. Do you have a good battery to swap it out with ? Also have you checked all the connections for loosened connectors or dirty connections? Once you eliminate that area then you can move forward from there. Let us know how that goes.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
A battery can show 12 volts all day long but under a load it can go down hill real fast. Do you have a good battery to swap it out with ? Also have you checked all the connections for loosened connectors or dirty connections? Once you eliminate that area then you can move forward from there. Let us know how that goes.
I checked all the connections earlier today so I am going to pick a replacement battery up later and see if that does the trick as I am at a loss myself as to what else it might be.

Thanks for the response.
 

·
Premium Member
Joined
·
5,898 Posts
Make sure you get the correct amperage battery too for your engine. Don't settle for a 250 amp for a big twin :) Is there a self diagnosis in your mower? If so there might be a troubleshooting guide in your operators manual. Have you confirmed all of your safety switches are hooked up and working ? Just want to make sure you didn't overlook something before you spend money. :2th:
 

·
Senior Member
Joined
·
1,329 Posts
sometimes I forget to shut off the mower deck from operating position! You might try to TAP on the starter,preferably while in start mode. might require a helping hand.
Honestly, my best guess at this point is a bad Batt. or conections. if setting for a while the connections will corrode @ the batt. or @ the starter connection.
 

·
Ret. Moderator
Joined
·
498 Posts
There should also be another safety under your seat , check that . Grab a bottle of COKE and pour some on your battery connections or water mixed with baking soda , this will clean any corrosion on the terminals . What is the overall condition of your terminal ends ?
 
1 - 9 of 9 Posts
Top