My Lawnmower Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
Having trouble with me 22 HP garden tractor with B&S twin engine. It was running kinda rough, changed plugs, filters, gas filter, oil, but still ideld rough and lost power while mowing. Added Seafoam, as recommended by a brother, and now it idles much better, but still gets rough under a load, such as engaging the mower deck -- sputters, poor power, jerks and misses. Occasionally backfires when shut off. Any ideas, guys?
 

· Registered
Joined
·
29 Posts
Discussion Starter · #4 ·
Thanks guys. I took off all the necessary stuff, but haven't removed the flywheel. (Been constantly assailed with other problems that bear priority -- otherwise known as "honey-dos"). However, I can see the key between the flywheel and the crankshaft and it appears OK. The magnet on the flywheel appeared to be very rusty, so I cleaned it off with a buffing block used for rust removal. Either of you know the required gap between the flywheel and the armatures? Maybe that's off a bit. :confused:
 

· Registered
Joined
·
29 Posts
Discussion Starter · #6 ·
Well, guys, I'm making no headway on this. My brother went to the B&S website and asked for help. The guy there suggested a carb rebuild, so I'll try that. Thanks for your help, though, and I'll keep you updated.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top