My Lawnmower Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi from southwest Florida, great to find some like minded folks. We have an XMark ZTR we use for mowing and a 69' Gravely Convertible 7.6 mower to beat the woods back with. Herein lies the problem. The Gravely has always been reliable for mowing, and for the first time, I tried a small tiller that came with it, a univator?, which worked great for the first hour. Now it won't stay engaged and keeps jumping out of gear while tilling, the tiller stops turning, even when holding back on the rod that engages the attachments. Any ideas? Thanks in advance for any comments.
 

·
Premium Member
Joined
·
5,898 Posts
Welcome to the forum! I'm located in Lake County, nice to see a fellow Floridian!
I'm not familiar with univator but I'll have to look it up and see what I can find. One of our other members might jump in before hand. I'll monitor and see if you get some help, meanwhile take a look around the forum.
 

·
Premium Member
Joined
·
5,898 Posts
Have you checked the clutch on the attachment point, and does the chain drive on the univator turn freely?
 

·
Premium Member
Joined
·
5,898 Posts
Another thought, have you tried putting the mower back on? If it doesn't work it may be an internal pto linkage problem and not a tiller problem.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Thanks for the message, yeah the univator looks to be much older than the 69' Gravely and has Berkeley Calif. stamped on it which somehow doesn't seem right. Trying to get a garden going down here in the Fort Myers sand.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
The clutch at the attachment point seems to be engaging properly, although I'm not sure what "normal" looks like on it. Good idea about the mower attachment, I'll put it back on and give it a try, I just assumed it was a clutch problem.
 

·
Premium Member
Joined
·
5,898 Posts
They are made in Berkely Calif. Did you get a chance to check those areas out yet?

Univator.jpg

Thought you'd like the ad.
:cool
 

·
Premium Member
Joined
·
5,898 Posts
There is a big linked chain that drives the cultivator head. You can remove a side cover to view it. If the mower works, Id check out the gearboxes and chain drive on the cultivator.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #10 ·
Put the mower attachment back on, it does the same thing, won't stay engaged. Cool advertisement on the univator, any idea how old?
 

·
Premium Member
Joined
·
5,898 Posts
Either binding of the external linkage or broken or worn internal PTO shifting mechanism. Probably have to take it apart and insect the PTO section for starters.
 

·
Premium Member
Joined
·
5,898 Posts
As far as the year, I think it was @ the late 60s. I might get corrected here but, the Univator was advertised and sold by Gravely dealers but was not made by Gravely. :dunno:
 
1 - 12 of 12 Posts
Top