My Lawnmower Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Back in the spring I decided I needed to replace the carb on my Snapper 33" Yard Cruiser (14.5hp Briggs) due to a crack in the carb body. I got a new carb and was re-installing it but I seem to have lost one of the linkages. It is the one that opens the choke back up. The govenor and choke "on" linkage were still where I left them. I can post a picture tomorrow if it helps. I ordered what I thought was the missing linkage but can't for the life of me figure out where it goes. We've been experiencing drought conditions down here this summer and so I didn't get in a big hurry fixing it until a few weeks ago. My father-in-law bought it new in '98 but probably didn't have more than 25 hors on it when he gave it to me 5 years ago. Following is the model/type etc from the engine.

Thanks, Steve

Model 287707
Type 0122-01
Code 970424ZE
 

· Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
Go to this link if you can:

http://bsintek.basco.com/BriggsDocumentDisplay/Z6hrsJVJ1DajI.pdf

Page 6

I think that the choke link goes to the same lever that controls the throttle. Connects to the choke control from the bottom, up thru the hole from the bottom.
I downloaded that manual and ordered the link #202 from page 6. Here is a pic of the carb etc. I think you are right Brad, I just can't get it oriented correctly. You can see the link from the governor and the curved one that sets the choke. The missing one is laying on teh engine deck.

 

· Registered
Joined
·
11 Posts
Discussion Starter · #9 ·
Yep

So maybe I'm not crazy? That picture is exactly what I have. Maybe the problem isn't a missing link, it's more me not understanding how the system works. I'll probably put it back together tomorrow and see what happens. Lesson learned? I have a digital camera. Take a picture before I take anything apart next time. Will let you know what happens. BTW Mark, excellent website. :D
 

· Registered
Joined
·
11 Posts
Discussion Starter · #11 ·
Thank you, thank you, thank you!

Well, I got it started and it ran fine with the linkage set up like it was. It hasn't run that smooth since I got it. I mowed the whole yard (Yes, we have stuff growing down here, weeds :) ). Shut it down in the drive way to clean it off before I put it in the garage. But, the end coil spring popped out of the outside key slot and I'm not sure it will stay in but I'm going to try it. Probably needs a new spring so I will take it to my buddy with the repair side business and tell him to bring it back to me when it's fixed :D . Any how, thank you again for your willingness to help and I will most definitely be upgrading my membership once things pick up financially for me.
 

· Registered
Joined
·
11 Posts
Discussion Starter · #13 ·
Spring

The outer end of the spring won't stay in the key slot. One side of the tab is all boogered up so I guess I'm ordering a new spring. May just get a new recoil starter if my buddy can get me one cheap enough. Installing those springs is a tedious process :eek:.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top