My Lawnmower Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·
Hello everyone. I have a MTD yard machine with the B&S 550 EX. I've worked on these engines numerous times since a ton of mowers being sold either have the 550 (Primer bulb) or the 550 EX (automatic choke).

It will only start with a shot of carb cleaner (into the mouth of carb) then runs great. Shut it off, immediately try to restart....nothing...needs a shot of carb cleaner and will run great again.

Like I said, I'm fairly experienced but this has me stumped. Here is a list of things I've tried.
New properly gapped spark plug
Properly gapped Overhead valves
Great spark
Drained gas and used 90 octane ethanol free
Cleaned carb (twice). Made sure that small pin hole was clean/clear
Auto choke working perfectly (closed when cold) opens when it warms up.
Took gas cap off ... still no luck
Checked the backside of the carb and made sure o-ring and retaining clip were still in place.

It seems like it's got to be sucking air from somewhere.

Thanks in advance.

Tango
 

·
Registered
Joined
·
201 Posts
I do not know much about the newer plastic carbs used on those, however i wonder if the float level is off and it is running to lean (not enough fuel, or too much air) making starting hard... even with the choke closed.
also make sure the choke is closing 100% as sometimes if there is a small gap, that can cause an issue.
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #3 ·
SOLVED this issue.

That pinhole in the white plastic has always been the culprit on every plastic carb I've ever worked on. Saw another thread that that white plastic part can be pried up and there are three tubes (jets???) one of the three was completely clogged. Cleaned it out. Reassembled everything and gave it an easy pull. VROOOM

Case closed

Tango out.
 
  • Like
Reactions: Scrubcadet10
1 - 3 of 3 Posts
Top