My Lawnmower Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a Troy-Bilt 6.5 HP push mower with starting/ running issues.
Model 12A-466A711
Engine model 123K02
The engine won't start. When I take the filter off and the primer plate from the carb everything looks ok. The primer also doesn't work. It just pushes air but no fuel.
I cleaned the carb and checked the plug.
I was able to start for a second or two several times with starting fluid.
It won't run more than that. I can't see any fuel going into the carb.
I checked the fuel line at both ends and there is fuel in the line.
Do you think this is a fuel plump/ carb issue? If so, I'm assuming the mower is a waste.
 

·
Premium Member
Joined
·
9,015 Posts
Hi, sounds like the primer may have hole in it or air leak. I believe it to be gravity feed system. Did you check fuel flow from tank to carb inlet? Maybe clogged?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Thanks for all the responses. I believe while I have it apart I'm going to buy the Carb overhaul kit B&S 498260. This will also give me the primer gasket to double up on (thanks 43128). I saw the video and it makes sense that filter cover is warped since its just plastic.
When I removed the bowl screw gas came out and continued to flow. I had to pinch the main line to stop the flow so that's a good sign.
I hope you agree that since I have it off that I should clean and do the overhaul.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Well, absolutely no luck. Doubled up on the gaskets and still no gas will come up from the bowl. I blew the main jet out good with carb cleaner and its completely free. What else do I do? It wont pull gas from the bowl.
The primer won't pull gas up either. The primer looks good but feels like it's just blowing air out. Any thoughts?
 

·
Registered
Joined
·
730 Posts
I would not worry about the primer bulb and lack of gas coming up, right now...yes, it will be critical later...but, main concern is why eng will Not continue to run after you manually prime it with starter spray...If the main jet is clear, as you say, and the bowl had gas in it...Eng has to stay running beyond the initial fire up...I would not spend money on the carb kit, yet...Perhaps you have a gapping hole somewhere in inlet pipe gaskets...
 
1 - 7 of 7 Posts
Top