Z-737 Stalling When Handles Pulled Back - Lawn Mower Forums : Lawnmower Reviews, Repair, Pricing and Discussion Forum
ZTR and Commercial As the lawns get bigger, so do the machines used to keep them looking good!

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 09-09-2019, 12:27 PM Thread Starter
Junior Member
 
Join Date: Aug 2016
Location: LA (Lower Alabama)
Posts: 7
Thanks: 3
Thanked 2 Times in 2 Posts
Z-737 Stalling When Handles Pulled Back

I have a John Deere Z-737 mower. Lately when I use it and I am going forward and pull back on the handles it wants to and sometimes dies on me. I thought maybe it is fuel starvation and changed the fuel filter which didn't help. Now its to the point of shutting off so often I cannot mow with it. All the fluid levels are good and the air cleaner is good. Suggestions?
DeputyDawg is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 09-12-2019, 12:42 PM
Junior Member
 
Join Date: Jun 2018
Posts: 6
Thanks: 0
Thanked 1 Time in 1 Post
I own a 757 and it has the Kaw engine. I found out that the engine has issues with getting too hot. I was having similar issues and found out that the fuel bowl on the carb had warped just enough to catch the float when the mower got hot. It would idle but then the fuel starvation started as I tried to speed it up. Pulled the carb, looked inside the bowl and ended up taking a file and removing about .002 from the back side of the bowl (away from the float pivot). Not sure but hope this helps...
laabk2 is offline  
post #3 of 4 (permalink) Old 09-13-2019, 12:41 PM Thread Starter
Junior Member
 
Join Date: Aug 2016
Location: LA (Lower Alabama)
Posts: 7
Thanks: 3
Thanked 2 Times in 2 Posts
I had a suggestion from another forum that it may be the Seat Switch. So I unplug it and jumped it and that corrected the problem. I ordered a new switch.

Again, thanks for the replies.

ddawg
DeputyDawg is offline  
The Following User Says Thank You to DeputyDawg For This Useful Post:
Mark / Ohio (09-14-2019)
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 09-14-2019, 12:31 AM
Administrator
 
Mark / Ohio's Avatar
 
Join Date: Aug 2010
Location: Central Ohio USA
Posts: 5,853
Thanks: 351
Thanked 699 Times in 609 Posts
Garage
Thanks for letting us know what you found.

Mark - 2002 John Deere LT150H

Mark / Ohio is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Lawn Mower Forums : Lawnmower Reviews, Repair, Pricing and Discussion Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome