JD L120 Not Charging - Lawn Mower Forums : Lawnmower Reviews, Repair, Pricing and Discussion Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 10-30-2019, 12:21 PM Thread Starter
Junior Member
 
Join Date: Oct 2015
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
JD L120 Not Charging

My L120 does not charge the battery. It goes dead after running a couple times. When I remove the battery and put it on a charger, the battery takes the charge and the tractor operates fine.

I understand auto engines and alternators, but the tractor system confuses me. What and where do I look and test or replace?
brown7373 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-06-2019, 04:33 PM
Junior Member
 
Join Date: Nov 2018
Posts: 6
Thanks: 0
Thanked 1 Time in 1 Post
This should help you.

philetus is offline  
post #3 of 3 (permalink) Old 11-12-2019, 07:45 PM
Senior Member
 
keakar's Avatar
 
Join Date: May 2016
Location: louisiana
Posts: 463
Thanks: 6
Thanked 15 Times in 15 Posts
i doubt you have a voltage regulator on that, if you do the video above shows how to check it

to replace the charging coil all you need to do is pull off the flywheel and i bet the charging coil is burnt

its easy fix but the flywheel can be a pain to get off sometimes

You can only learn if you ask the question, so there are no dumb questions.
keakar is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Lawn Mower Forums : Lawnmower Reviews, Repair, Pricing and Discussion Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome